दिलचस्प पोस्ट
बूटस्ट्रैप टूलटिप्स काम नहीं कर रहे हैं डिज़ाइन का समय सेट करना एक विंडो पर डाटाकॉन्टेक्स्ट एक कंपाइलर त्रुटि दे रहा है? सी ++ 11 की श्रेणी-आधारित उपयोग करने का सही तरीका क्या है? सीएसआरएफ राज्य टोकन एक प्रदान किए गए एफबी PHP एसडीके 3.1.1 औथ 2.0 से मेल नहीं खाता है लिनक्स के लिए पायथन का उपयोग करके कुंजी प्रेस इवेंट का अनुकरण करना कैसे बाइट सरणी को स्ट्रिंग और इसके विपरीत रूपांतरित करने के लिए प्रतिशत आधारित आईओएस लेआउट बनाना जावा 8 का वैकल्पिक तर्क तर्क में क्यों नहीं किया जाना चाहिए NSDictionary में शून्य मान का पता लगाएं PHP5 के PDO rowCount MySQL समस्या के लिए कार्य-आसपास क्या डेटा हेरफेर और हैंडलिंग के लिए ऐपडैलेगेट का उपयोग करना अच्छा अभ्यास है? दो निर्देशांकों के बीच की दूरी की गणना करने के लिए कार्य गलत दिखाता है जब एक चर का दायरा खत्म हो जाता है तो क्या होता है? एंड्रॉइड यूनिट परीक्षणों के लिए डेटा फ़ाइलों को कैसे प्रदान करें PHP में सुरक्षित यादृच्छिक संख्या पीढ़ी

कोई संसाधन नहीं मिला – थीम। ऐप कॉमपेट। हल्का। डार्क ऍक्शन बैंक

मैंने एक्शनबार स्टाइल जेनरेटर का इस्तेमाल किया, और अब मेरे ऐप में उपयोग करने की कोशिश कर रहा हूं, लेकिन हो रही है:

त्रुटि: आइटम के लिए अभिभावक पुनर्प्राप्त करने में त्रुटि: कोई संसाधन नहीं मिला जो दिए गए नाम से '@ शैली / थीम.AppCompat.Light.DarkActionBar' से मेल खाता है।

मैं एंड्रॉइड-समर्थन- v7-appcompat.jar lib का उपयोग कर रहा हूँ libs फ़ोल्डर में

मेरा लक्ष्य मेरे ऐप को 2.3 या उससे ऊपर के संगत बनाना है

Solutions Collecting From Web of "कोई संसाधन नहीं मिला – थीम। ऐप कॉमपेट। हल्का। डार्क ऍक्शन बैंक"

AppCompat एक पुस्तकालय परियोजना है आपको अपने एंड्रॉइड प्रोजेक्ट में लाइब्रेरी प्रोजेक्ट का संदर्भ देने की आवश्यकता है।

संसाधनों के साथ पुस्तकालय जोड़ने विषय विषय की जाँच करें।

यदि आप ईक्लिप्स का उपयोग कर रहे हैं, तो निम्नलिखित चरणों के रूप में अपनी प्रोजेक्ट में reference library जोड़ें:

  1. Project Explorer व्यू में अपने प्रोजेक्ट को राइट-क्लिक करें
  2. Properties क्लिक करें
  3. Properties विंडो में Android क्लिक करें।
  4. Library समूह में, Add... क्लिक करें Add...
    • नीचे दी गई छवि देखें
  5. लाइब्रेरी का चयन करें OK क्लिक करें
  6. गुण विंडो में फिर से OK बटन पर क्लिक करें।

परियोजना गुण विंडो, एंड्रॉइड अनुभाग, लाइब्रेरी समूह में "जोड़ें" बटन।

यदि आप एंड्रॉइड स्टूडियो प्रयोग कर रहे हैं तो बस निर्भरता जोड़ें

 dependencies { compile 'com.android.support:appcompat-v7:25.0.1' } 

app/build.gradle के लिए और वह काम करेगा

यदि आप ईक्लीपस का उपयोग कर रहे हैं, तो आप संसाधनों का उपयोग करने जा रहे हैं, तो libs फ़ोल्डर के लिए android-support-v7-appcompat.jar को कॉपी करने से काम नहीं करेगा।

" संसाधनों के साथ पुस्तकालय जोड़ने " के लिए यहां से कदम उठाएं

एक सरल समाधान – सामग्री को प्रतिस्थापित करें इस फाइल (/res/values/styles.xml) को यह पाठ है:

 <resources> <!-- Base application theme. --> <style name="AppTheme" parent="android:Theme.Holo.Light.DarkActionBar"> <!-- Customize your theme here. --> </style> 

वीएस2015 का उपयोग करने वाले किसी के लिए, मुझे यह त्रुटि भी मिल रही है, और यह पता चला है कि मैंने इस परियोजना में पुस्तकालय नहीं जोड़ा था …

 Install-Package Xamarin.Android.Support.v7.AppCompat 

मेरे मामले में, मैंने एक कंप्यूटर से दूसरे कंप्यूटर को एक android प्रोजेक्ट ले लिया और इस समस्या को मिला। मेरे लिए जो काम मैंने देखा है उनमें से कुछ का एक संयोजन था:

  • ऐप्परपाट लाइब्रेरी की प्रतिलिपि निकालें जो वर्कस्पेस के लिब्स फ़ोल्डर में थी
  • एसडीके 21 स्थापित करें
  • उस एसडीके बिल्ड का उपयोग करने के लिए प्रोजेक्ट प्रॉपर्टी बदलें यहां छवि विवरण दर्ज करें
  • सेट अप करें और एसडीके 21 के साथ संगत एमुलेटर शुरू करें
  • चलाने के लिए डिवाइस को चलाने के लिए संकेत करने के लिए रन कॉन्फ़िगरेशन को अपडेट करें और रन चुनें

इन चरणों के बाद मेरा ठीक चल रहा था

सुनिश्चित करें कि आपके एसडीके में एक v7 निर्देशिका है, मुझे लगता है कि 'एंड्रॉइड सपोर्ट लाइब्रेरी' (अतिरिक्त में) पर्याप्त था। बाहर निकलता है मैं 'समर्थन पुस्तकालयों (अतिरिक्त; एंड्रॉइड; एम 2 रिकॉस्पिटरी) के लिए' स्थानीय मैवेन रिपॉजिटरी 'याद कर रहा था' स्टूडियो ने पाया कि वास्तव में और gradle निर्भरता तय की निर्माण करने के लिए gradle का इस्तेमाल करते हुए काम किया। $ बिल्ली ऐप / build.gradle

 apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "pat.example.com.gdbdemo" minSdkVersion 15 targetSdkVersion 23 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:23.2.1' } 
 dependencies { compile 'com.android.support:appcompat-v7:23.0.0' } 

यह एंड्रॉइड स्टूडियो में मेरे लिए काम किया …

विजुअल स्टूडियो 2015 (विंडोज 7) + एक्समारिन का उपयोग इस त्रुटि और कई चीजों की कोशिश करने के बाद (संकुल को स्थापित करने, एंड्रॉइड-एम 2 रिपॉझिटरी_र 10.ज़िप डाउनलोड करें …) ने पूर्ण ज़ैमरिन फ़ोल्डर को अंदर से समाप्त कर दिया।

 C:\Users\<my user>\AppData\Local 

उसके बाद, वीएस में एप्लिकेशन को फिर से बनाना और त्रुटियों को गायब किया गया।

  1. प्रबंधक में अपने एसडीके को अपडेट करें और अतिरिक्त Android support library में Android support library को शामिल करना सुनिश्चित करें
  2. फ़ाइल एक्सप्लोरर (मैक पर फ़ाइंडर) में SDK पर जाएं अतिरिक्त फ़ोल्डर को ट्रैक करें ( ..\sdk\extras\android\support\v7\appcompat\res\values Windows पर) कहीं एक themes_base.xmlthemes_base.xml और themes_base.xml इन दोनों फाइलों की कॉपी करें
  3. अपनी परियोजना में फ़ाइलों को 'मान' निर्देशिका में पेस्ट करें

एक्लिप्स में: समर्थन लाइब्रेरी जोड़ने पर निर्देशों का पालन करते हुए प्रोजेक्ट लायब्रेरी के रूप में एक सहायता लायब्रेरी आयात करते समय, "कार्यस्थान में प्रतिलिपि कॉपी" विकल्प को न भूलें !

मुझे भी बिल्कुल यही समस्या है। यहां सूचीबद्ध समाधानों में से कोई भी मेरी स्थिति की मदद नहीं करता है। जैसा कि यह पता चला है, मैं प्रोजेक्ट फ़ोल्डर के बजाय, एंड्रॉइड स्टूडियो 1.5 में एक प्रोजेक्ट के मूल फ़ोल्डर को आयात कर रहा था। इसने ग्रिडेल को एक चिड़चिड़ा में फेंक दिया हल करने के बजाय परियोजना फ़ोल्डर आयात करना था