दिलचस्प पोस्ट
मैं नोड.जेएस वेब अनुप्रयोग में मोंगोडीबी कनेक्शन कैसे प्रबंधित करूं? Asp.net पहचान पासवर्ड हैशिंग mylib.so पाठ पुनर्स्थापना है यह स्मृति बर्बाद कर रहा है और एक सुरक्षा जोखिम है। कृपया ठीक करें सी # में Process.MainModule.FileName तक पहुँचने पर Win32 अपवाद से कैसे बचें? दी गई तिथि के सही सप्ताह संख्या प्राप्त करें ओपनसीवी में कैमरा कैप्चर रिज़ॉल्यूशन बढ़ाना Google मानचित्र एपीआई V2 'मानचित्र लोड करने में विफल Google सर्वर से संपर्क नहीं किया जा सका क्यों 0.1f से 0 को 10x से नीचे प्रदर्शन धीमा कर देता है? अलग ढाल के साथ स्विंग बटन को फिर से रंगना एंड्रॉइड एडीबी डिवाइस ऑफ़लाइन, आदेशों को जारी नहीं कर सकते DataGridView को सूचीबद्ध कैसे करें? क्या जॉन रेसिग का जावास्क्रिप्ट इनाम स्निपेट बहिष्कृत है? कैसे एक JTextField मान्य है? गति के लिए preallocating विचार MVC में ViewModel क्या है?

हल करने में विफल: com.google.firebase: firebase-core: 9.0.0

पुराने डोमेन से नए Google फायरबसे डोमेन पर फ़ायरबसे प्रोजेक्ट को नवीनीकरण करते समय मुझे निम्न त्रुटि मिलती है।

हल करने में विफल: com.google.firebase: firebase-core: 9.0.0

मैं फ़ायरबेज प्रलेखन पर उल्लिखित चरणों का पालन करता हूं, अनुभाग में फायरबसे को अपने एंड्रॉइड प्रोजेक्ट, विषय उपलब्ध पुस्तकालयों में जोड़ें ।

इस त्रुटि को हल करने के लिए मेरे विकल्प क्या हैं?

Solutions Collecting From Web of "हल करने में विफल: com.google.firebase: firebase-core: 9.0.0"

अगस्त 2017 को अपडेट करें

संस्करण 11.2.0 रूप में, 11.2.0 और Google Play सेवाएं निर्भरता Google के 11.2.0 रिपो के माध्यम से उपलब्ध हैं। इन निर्भरताओं को आयात करने के लिए अब आपको एंड्रॉइड एसडीके मैनेजर का उपयोग करने की आवश्यकता नहीं है

अपने रूट build.gradle फ़ाइल में रेपो जोड़ें:

 allprojects { repositories { // ... maven { url "https://maven.google.com" } } } 

यदि आप gradle 4.0 या उच्चतर का उपयोग कर रहे हैं तो आप केवल google() साथ maven { url "https://maven.google.com" } को बदल सकते हैं।


फायरबेज के 9.0.0 संस्करण Google Play सेवाओं 9.0 का उपयोग करके बनाया गया था और अब यह नई पैकेजिंग के तहत उपलब्ध है com.google.firebase:*

Google Play सेवाओं के लिए रिलीज नोट्स देखें 9.0 https://developers.google.com/android/guides/releases#may_2016_-_v90

पैकेजों के नए संस्करण Google Play सेवाएं (rev 30) और Google रिपोजिटरी (rev 26) को अभी एसडीके प्रबंधक में जारी किया गया है, इसलिए संभव है कि आपको अपडेट करने की आवश्यकता हो।


Google Play सेवाएं और Google रिपॉजिटरी डाउनलोड करना

एंड्रॉइड स्टूडियो से:

  1. Tools > Android > SDK Manager क्लिक करें
  2. SDK Tools टैब पर क्लिक करें
  3. Google Play Services (rev 30) और Google Repository (rev 26) का चयन करें और इंस्टॉल करें। नीचे दी गई छवि देखें
  4. Sync और अपना प्रोजेक्ट Build

यहां छवि विवरण दर्ज करें


इंटेलीज आईडीईए से:

अप्रैल 2017 तक, Google Play सेवाएं और रिपॉजिटरी के नवीनतम संस्करण नीचे सूचीबद्ध हैं

  1. Tools > Android > SDK Manager क्लिक करें
  2. Packages पैनल के अंतर्गत Extras
  3. Google Play Services (Rev 39) और Google Repository (Rev 46) का चयन करें और इंस्टॉल करें। नीचे दी गई छवि देखें
  4. Perform a gradle project sync और अपनी प्रोजेक्ट Build

अप्रैल 2017 तक एसडीके प्रबंधक की अद्यतन छवि

एंड्रॉइड एसडीके प्रबंधक पर जाएं और नीचे दो पुस्तकालयों का नवीनतम संस्करण इंस्टॉल करें

  1. Google Play सेवाएं
  2. Google रिपोजिटरी

Error:(30, 13) Failed to resolve: com.google.firebase:firebase-auth:9.6.1

यदि आपको कभी भी यह त्रुटि मिलती है और आप एंड्रॉइड स्टूडियो 2.2 का उपयोग कर रहे हैं जो कि फायरबेज घटक के साथ एकीकृत है जिसमें पुस्तकालय संस्करण 9.6.0 डिफ़ॉल्ट रूप से है और आप 9.6.1 जैसी नवीनतम निर्भरता जोड़ रहे हैं। आपको com.google.firebase:firebase-auth:9.6.1 डाउनग्रेड करना पड़ सकता है com.google.firebase:firebase-auth:9.6.0 से com.google.firebase:firebase-auth:9.6.0

या अपने पूर्व-स्थापित फायरबसे के पुस्तकालय संस्करण की जांच करें और सुनिश्चित करें कि आप उसी प्रोजेक्ट की नई लाइब्रेरी के साथ जोड़ना चाहते हैं जो आपकी परियोजना में जोड़ या जोड़ रहे हैं।

अपने आप का सामना किया और इसी तरह के सवालों के लिए टिप्पणियों में कई बार देखा – कि "नवीनतम" Google Play सेवाएं और Google रिपॉजिटरी इंस्टॉल करने के बाद भी एक ही समस्या हो रही है।

यह बात यह है कि वे आपके एंड्रॉइड एसडीके उपकरणों की वर्तमान संशोधन के लिए नवीनतम हो सकते हैं, लेकिन यह नहीं कि आपके ऐप के निर्माण की आवश्यकता है

ऐसे मामले में पहले एंड्रॉइड एसडीके टूल के नवीनतम संस्करण को स्थापित करना सुनिश्चित करें, और संभवत: एंड्रॉइड एसडीके प्लेटफार्म-टूल्स (दोनों टूल्स शाखा के अंतर्गत)। इसके अलावा कृपया ध्यान दें, यदि आपको लंबे समय तक अपडेट नहीं किया गया है (यानी नवीनतम एंड्रॉइड एसडीके उपकरण और एंड्रॉइड एसडीके प्लेटफार्म-टूल्स स्थापित करें , फिर एंड्रॉइड एसडीके मैनेजर को दोबारा दोबारा दोबारा दोबारा दोबारा दोबारा दोबारा दोबारा दोबारा दोबारा दोबारा दोबारा दोबारा दोबारा), तो कृपया ध्यान दें कि आपको कई बार इस माध्यम से जाना होगा कुछ महत्वपूर्ण अनिवार्य मील के पत्थर के माध्यम से जाने के लिए और यदि आप वर्तमान में संशोधन है जो बहुत पुराना है, तो आप बहुत नवीनतम स्थापित नहीं कर सकते।

एंड्रॉइड एसडीके प्रबंधक - उपकरण और प्लेटफार्म-टूल्स

यदि आप अपने प्रोजेक्ट में फायरबसे जोड़ना चाहते हैं तो निम्नलिखित आवश्यकताएं हैं।

  1. फायरबेज के साथ काम करने के लिए आपको एंड्रॉइड स्टूडियो 1.5 या उच्चतर इंस्टॉल करना चाहिए।
  2. एंड्रॉइड एसडीके प्रबंधक के माध्यम से नवीनतम Google Play सेवाएं एसडीके डाउनलोड करें
  3. डिवाइस को एंड्रॉइड 2.3 (जिंजरब्रेड) या नए और Google Play सेवाएं 9.2.0 या नए चलाना चाहिए।

संघर्ष के कुछ घंटों के बाद मैं यह सब पता कर सकता था

स्रोत: अपने एंड्रॉइड ऐप में फायरबसे जोड़ना

यदि कमांड लाइन टूल्स का उपयोग करते हैं, तो करें

 sdkmanager 'extras;google;m2repository' sdkmanager 'extras;android;m2repository' 

अद्यतन करने की आवश्यकता है

एंड्रॉइड एसडीके: एसडीके उपकरण -> समर्थन रिपोजिटरी -> Google रिपोजिटरी

एंड्रॉइड एसडीके को अपडेट करने के बाद एंड्रॉइड स्टूडियो में ग्रेडेल बिल्ड को सिंक्रनाइज़ करने की आवश्यकता है।