दिलचस्प पोस्ट
मैं CodeIgniters URL रूटिंग काम करने के लिए एक .htaccess फ़ाइल कैसे लिख सकता हूँ? ट्विटर बूटस्ट्रैप 2.0 का उपयोग करना – समान स्तंभ ऊंचाइयों को कैसे बनाया जाए? जावा में एक गैर-सीरिजलाइज़ करने के लिए कैसे करें? मीडियास्ट्रीम कैनवास कैद और ऑडियो को एक साथ आईओएस 10 नक्शे के नीचे शीट की नकल कैसे करें I jQuery – कैसे 'आकार' के 'अंत' के लिए प्रतीक्षा करने के लिए घटना और केवल तब एक कार्रवाई करने के लिए? क्यूटी 5 में अतिभारित सिग्नल और स्लॉट को कनेक्ट करना सी / सी ++: गैर-पूर्णांक के लिए स्विच IPhone में पुनः अभिविन्यास के बाद "गलत" फ्रेम / विंडो आकार कॉर्डोबा बिल्ड: कृपया एंड्रॉइड -22 "एंड्रॉइड लक्ष्य स्थापित करें" मुझे एंड्रॉइड -22 नहीं चाहिए I मैं एंड्रॉइड -19 चाहता हूं – मैं क्या करूँ? क्या एक खोल स्क्रिप्ट कॉलिंग शेल के पर्यावरण चर सेट कर सकता है? LINQ में सूची समतल करें फ़ायरफ़ॉक्स में href = "फाइल: ///// …" के लिए वैकल्पिक हल बाश में एक सरणी में विभाजित स्ट्रिंग कन्स्ट्रक्टर आरंभक में एक सदस्य सरणी को प्रारंभ करना

जावा असमर्थित प्रमुख लघु संस्करण 52.0

मैं एचटीएमएल में एक वेब एपलेट के रूप में अपना जावा एप्लिकेशन लॉन्च नहीं कर सकता (मैं एचटीएमएल 4.01 का इस्तेमाल कर रहा हूं, मुझे पता है कि यह html5 में काम नहीं करता है)। यह जो त्रुटि संदेश देता है वह है:

java: असमर्थित प्रमुख। मिनोर् संस्करण 52.0

मैंने अपने जावा जेआरई / जेडीके / एसडीके को डाउनग्रेड करने की कोशिश की है लेकिन मुझे अभी भी एक ही त्रुटि संदेश मिलता है अब जावा का वर्तमान संस्करण 1.8.0_05 है I

Solutions Collecting From Web of "जावा असमर्थित प्रमुख लघु संस्करण 52.0"

आपका कोड जावा संस्करण 1.8 के साथ संकलित किया गया था, जबकि यह जावा संस्करण 1.7 या नीचे के साथ निष्पादित किया जा रहा है।

आपके मामले में ऐसा लगता है कि दो अलग-अलग जावा इंस्टॉलेशन का उपयोग किया जाता है, नए को संकलित करने और पुराने को आपके कोड को निष्पादित करने के लिए।

अपने कोड को जावा 1.7 के साथ पुनः कंपाइल करने का प्रयास करें या अपने जावा प्लगइन का नवीनीकरण करें

आपको जावा 1.7 के साथ संकलित करना होगा लेकिन अगर आपके पास * .jsp फाइलें हैं, तो आपको सिस्टम से पूरी तरह से जावा 1.8 को हटा देना चाहिए। यदि आप मैक का उपयोग करते हैं, तो यह है कि आप इसे कैसे कर सकते हैं।

मैंने देखा है कि नेटबींस में सर्वर टैब में अपाचे कॉन्फ़िगरेशन आप अपने वेब अनुप्रयोग के लिए मंच बता सकते हैं मैं 1.8 में बदल गया और यह ठीक काम किया। (मैं अपने आवेदन में जावा 8 प्लेटफॉर्म को लक्षित कर रहा हूं)। आशा है कि संभवतः मदद नहीं करेगा

मुझे लगता है कि openjdk8 tomcat8 के साथ काम करेगा, लेकिन मुझे इसे हटा देना था और केवल openjdk7 रखने के लिए, इस मामले को मेरे मामले में तय किया गया मुझे सच में पता नहीं है कि अगर कुछ और क्यों होता है तो मैं कर सकता था